Maintenance Commands LOOM(1M)
NAMEloom - Lock manager for hosts, files and other objects
SYNOPSISloom/gloom [-german] [-silent] [-s] [-verbose] [-v] [-debug] [-secure] [-help] [-h] [[-c] [-comment] COMMENT] [-lock] [-unlock] [-list] [-info] [-history] [ objects ... ]
DESCRIPTIONThe loom/gloom program is a lock manager for hosts, files and other targets. It uses a central directory for creating lock files with the SOURCE CODE CONTROL SYSTEM SCCS. This directory must be either accessable by a distributed filesystem or by remote shell access to the host where the directory resides. The default host name for this is loom. The loom/gloom program does not lock the target object itself, but provides the lock information to a set of tools which have been programmed to accept the loom/gloom mechan- ism as lock authority.
VERSIONVersion of this file @(#)loom.1 2.1.
OPTIONS-german Provide german messages. This is the default if you call loom as gloom. -silent | -s Do only a one line output for each target. The return status while using the options -lock and -unlock is 0 or 1. Without option -silent the status will be replaced by Done and Failure respectively. -verbose | -v Provide more verbose information which may not being program readable. The return status while using the SunOS 5.10 Last change: 1 Maintenance Commands LOOM(1M) options -lock and -unlock is a string. -debug Option for switching to debug mode. -secure Change from remote shell protocol (rsh/remsh) to secure shell protocol (ssh). -help | -h Print the actual option list. -comment COMMENT | -c COMMENT Use the given comment whenever possible within the lock mechanism as reason for the requested action and keep it in the history. -lock Lock the named objects. The return for each object is a string object:0 or object:Done on success, and object:1 or object:Failure on failure. The command return value can not be used, because possible rcommands may not handle it correctly. This would also inhi- bit to lock multiple object with one call. -unlock Unlock the named objects. The return for each object is a string object:0 or object:Done on success, and object:1 or object:Failure on failure. The command return value can not be used, because possible rcommands may not handle it correctly. This would also inhi- bit to unlock multiple object with one call. -list List the current lock state of the named objects. The return for each object is a string object: SCCS information -info List the current SCCS version of the named objects. The return for each object is a string SCCS information SunOS 5.10 Last change: 2 Maintenance Commands LOOM(1M) -history List the lock history of the named objects.
ENVIRONMENTThe following environment variables are supported: LOOMDIRS [loomserver:]loom_lock_directory SITE Used for automatic site customisation. SALAD_ROOT Fallback if no site or env customisation. REMSH Path of the remote shell program.
AUTHORThis tool is written by Thomas Finnern at DESY/Hamburg. Recommendations and questions may be send to firstname.lastname@example.org
COPYRIGHTCopyright 1996-1999, DESY/Hamburg This tool may be used freely within the HEP community. There will not be any warranty on the program.
SEE ALSOloom, gloom, wboom, gwboom, boom, gboom, woom, gwoom, salad, sudo SunOS 5.10 Last change: 3